PDA

View Full Version : help with arduino sketch



cliff smith
03-02-2014, 10:14 AM
hi all, im a newby and have got the bug !!! im trying to start of slow and easy having downloaded vixen 2 and bought a arduino uno board. im trying to control 12 solid state relays with simple on off commands from a vixen sketch. im having a little trouble writing the sketch. can anyone help
cheers cliff

LightUp
03-02-2014, 11:05 AM
hi all, im a newby and have got the bug !!! im trying to start of slow and easy having downloaded vixen 2 and bought a arduino uno board. im trying to control 12 solid state relays with simple on off commands from a vixen sketch. im having a little trouble writing the sketch. can anyone help
cheers cliff

Let's say the answer is yes. What kind of "help" are you asking for?
There have been numerous post on this site that do what you want to do, with accompanying sketches.
Have you read these posts in the ARDUINO section of this forum? If not, why? If yes, what was your difficulty?

cliff smith
03-02-2014, 05:05 PM
Hi thanks for reply, the trouble I'm having is that I copied and pasted a sketch to run 16 channels but every time I run the sequence a different channel switches on and off. I have just read a post that says arduino might not like a copied and posted sketch. So I'm going to try and right it manually.
Thanks cliff

LightUp
03-02-2014, 06:43 PM
You must have the same number of channels used in the sketch as Vixen uses.
For example, if your sketch is reading 16 channels but your Vixen sequence only sends 12 then you will have a mismatch.
Do you have a channel count mismatch?

cliff smith
03-03-2014, 03:44 AM
That's it mate I had a miss match thanks

codec101
03-03-2014, 04:58 PM
You should also take a look at this thread >

http://doityourselfchristmas.com/forums/showthread.php?31917-vixen-and-arduino-wrong-channel-output