PDA

View Full Version : Olsen 595 skips ... sometimes



scharbon
07-17-2007, 02:16 PM
When I run a series of test sequences through my 595, I get a few channles that do not always turn on. I assume the channels are not turning on because the LED indicator for that channel doesn't turn on (SSRs are not yet built - so I cannot be certain if it is the LED or the channel).

If I step through each channel 1 second at a time, I always end up with 2 or three that wont turn on. Sometimes its numbers 44, 52, and 64 that will not turn on - sometimes it is another combination of some other three. Never the same ones all the time. And never channels 1 through 32 (always between 33-64). If I turn on two at a time, then usually two or three wont turn on (rarely the same ones each time - even during the same run). But If I turn on 4 or more at a time, the correct LEDs always light up all the time - to include the ones that didn't turn on before.

I am running Windows XP and Vixen 1.1 on a P-II, 500 MHz, 512 RAM (old and slow) with most background software turned off. I have set my parallel port to bi-directional, EPP, and ECP with the same results for each setting. Only one I haven't tried is Output Only.

Could this be an "old computer" problem, a "you didn't build the 595 right" problem, or is it a "Vixen on my machine" problem? I would appreciate any assitance you can provide. Also, if this is the wrong forum area, please let me know so I can carry on my post in the right place.

Thanks in advance

Steve

WakeFan
07-17-2007, 03:39 PM
I would try to test each channel with Vixen. You have to be set up like you a going to run a sequence. The test button is at the top left corner of the screen. It has 2 boxes and 2 check marks. Then if they all work doing that, you know the board is okay.

scharbon
07-17-2007, 08:38 PM
Ran the test routine. Every light turns on when I click it. So I guess I built the board right. I guess it may be the signal from the computer to the board.

Maybe the computer cant keep up with vixen. If I get to a point in the routine when a chaneel is skipped, go back a few seconds and start it from that point, the LED turns on and then later in the sequence something else doesn't turn on. 's clock can't keep up with

Wayne J
07-17-2007, 09:11 PM
I read through an older thread about the different computer setups people are using. I saw nothing about P2 machines.
Do you have another computer to try it on?


This is the thread....
http://blinkyflashy.14.forumer.com/viewtopic.php?t=935

Mudsculpter
07-18-2007, 12:39 AM
I'm running a Pentium MMX 233mhz processor w/160MB memory and seems to run fine.

sandy
07-18-2007, 12:03 PM
Do you have the sequence preview running?
And / or is there a large picture image on it.

I've found that can slow things down and might account for the skipping.
Some of vix files went from 507K to 127k just be making the back image in the preview smaller and lower resolution.

scharbon
07-18-2007, 02:55 PM
Haven't even figured out how to use the sequence preview yet. Thinking I'll do that after I get the computer and board working together. I may try the board on another computer this weekend and see if it is just my old computer that is the problem.

------Edit-------

Fixed the problem. Thanks for all of your help. Issue was that while my parallel port was set to EPP or ECP, it was also set to "Auto" which only works with Plug and play hardware. I had to change the Parallel port configuration to "Enabled". Once I did that and reset the board from ECP (which worked best in the auto mode but was really bad in the enabled mode) to EPP it works great and all channels function exactly as they are supposed to.

Steve