PDA

View Full Version : HLS crashes when creating segment with all pixels



Petulka77
12-27-2013, 12:29 AM
I try to create segment including all my pixels (11K channels). But HLS crashes after clicking Save Changes.

angus40
12-27-2013, 01:00 AM
the definition of segment is >>> a portion of .

a crash should be expected .

try creating a display group or pixel plane instead !

Petulka77
12-27-2013, 01:49 AM
Thanks for reply but ...
The reason why I am trying to create a segment is: to handle all channels as 1 row.
If I create Display Group I will end up with 11K of rows in the grid. Once I was told that this is against the HLS logic.
Pixel plane does not make sense here.

angus40
12-27-2013, 02:38 AM
Maybe a master lighting channel may be of use here then ?

Petulka77
12-27-2013, 09:42 AM
Master lightning channel can help with intensity. I want to apply color effects.
There is a workaround for me now using multiple segments.
I reported this issue, because HLS crashes and I can reproduce it repeatedly.

Thanks for your help anyway.

JHinkle
12-27-2013, 10:16 AM
I just ran a test ... created a sequence with 12,000 channels --- test having the channels all RGB and tested all NON-RGB.

Created Segments - Displayed Segments, Added effects, removed effects --- all works great.

I did get a copy of your crash report.

I see where/why the crash occurred --- I don't understand how the channel got that way (not a fully developed channel with all of it memory components allocated).

I suspect you made some changes in Raw Channel that created this misformed channel (that's a hole I will need to understand and fill).

Have you tried Saving - Closing HLS - and restarting HLS and the sequence? If it is what I think it is - the process of Saving and then restarting should fix itself.

I have released Version 19H. I added an addition sanity check to the associated Segment channel to make sure it was fully developed.

Please test using 19H.

If that failes -- then I would ask that you zip and send me ONLY the PCM and HLS files (only those two files).

The crash report is very limited in debugging and you actual sequence would provide a much better picture of the issue.

I'm hoping 19H address it ... it only addresses the symptom -- not the root-cause of what caused the issue.

Joe

Petulka77
12-27-2013, 12:02 PM
Thank you Joe for looking at this.

I tested and restarted HLS in version without your fix and it did not help.
I got your latest version and it did not help either.

Here is the zip to PCM and HLS files (https://app.box.com/s/35hc19qkkrn6zpk6unng).

Thank you.

JHinkle
12-27-2013, 12:16 PM
What do I do to create the crash with your sequence after it's loaded?

Joe

Petulka77
12-27-2013, 02:40 PM
Just try to create a new segment with all channels (with universe > 0)

Save changes = error

JHinkle
12-27-2013, 02:49 PM
The issue was that you were creating a Segment that contained channels --- some with and some without BackGround data. I had a bug under those conditions.

Version 19J addresses it.

Joe

Petulka77
12-27-2013, 02:54 PM
Nice. Thank you Joe.