PDA

View Full Version : Dev Build crashes every time when trying to open a file on create a new one.



Bryan Greenwood
11-14-2013, 03:23 AM
The software is incredible and a huge time saver for programming my RGB tree...however I couldn't get the old graphical patching to work so opted to try a dev build with the new patching. Incredibly easier. thank you thank you! But then the second I try to open one of my sequences or create a new one it crashes every time. I have deleted the Vixen 3 folder, uninstalled and then re-installed repeatedly. I re-set up my elements with the color filter and set up my controller, do the patching and everything seems fine. Then try to create a new sequence and CRASH.

I am sure it is simple and I am just too much of noob to know what I have done wrong. Please help.

Here is the error message:

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at VixenModules.Editor.TimedSequenceEditor.TimedSeque nceEditorForm.TimedSequenceEditorForm_Load(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Mes sage& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.O nMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.W ndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

lutton
11-14-2013, 09:15 AM
Hi Bryan, if you want to zip up a copy of your V3 directory in the state where it will crash when you create a new sequence, I'd be happy to try it out here in the debugger.

Tnx,
Bill L.

sallz0r
11-19-2013, 01:05 PM
Hi Bryan -- any update on this? Would be good to track down what's causing the problems. My sincere apologies for any frustration it's caused!

Cheers,
Michael

Bryan Greenwood
11-22-2013, 12:11 AM
thank you for your kind offer to figure out why the program crashes on me every time I open a sequence or try to create a new one. File attached.

lutton
11-22-2013, 02:58 AM
Hmmm... I switched to your data directory and was able to create a new timed sequence with no trouble...

Maybe Michael will have better luck getting a crash (or maybe spot something else)?

Sorry,
Bill L.

sallz0r
11-28-2013, 01:37 PM
Hi Bryan,

Hmm, I've just had a look as well, and I can't reproduce it. Are you still having problems? If so, what version are you using?

I'm about to do a 3.0.10 release (might be out tomorrow), so I would be interested if you still have the problem with that one. From what I could see, it was a very standard setup with a single pixel megatree and a preview. Hmm....

Thanks,
Michael