View Full Version : Vixen 3 Controller Module Testing

07-30-2013, 03:20 PM
Looking for people willing to test or provide hardware to test controllers in Vixen 3.

The following controllers have been written and tested:

1. Renard
2. E1.31
3. Grinch
4. 595
5. Hill 320

The following controllers have been written and I have no idea if they have been tested:
1. OpenDMX
2. PSC
4. FGDimmer

If your controller is not listed please let us know what it is and we will see about getting it created.

07-30-2013, 05:07 PM
1. OpenDMX


08-04-2013, 01:32 PM
Derek -- what version?

Actually, Tony, what versions have you tested those ones with? 3.0.7 at all? I'm just trying to keep this list semi-up-to-date:



08-04-2013, 04:48 PM
Version .6 worked. I think it has worked longer. No extensive testing, just a couple RGB floods on a Ren48LSD.

08-04-2013, 08:45 PM
I used 3.0.6 to test with.

10-02-2013, 12:24 AM
Hi All, not sure how far it has gotten but a module for the helix controllers. I know Greg was talking with the development team but not sure how far it may have gone yet?

10-02-2013, 10:36 AM
Hi cullen_ryan,

I haven't heard too much about the helix -- there was some discussion/chatter, but no actual work or code that I've seen yet.


11-15-2014, 12:17 PM
I have tried using v3.1u1 with my Hill 320. It seems 3.1 can't keep up with the timing.
It misses some blinks, the mega tree skips and freezes.
v2.5 works great.

11-17-2014, 12:49 AM
I'm having the same issue with mine. Version 3.1 is okay but 3.1u1 freezes. I have a E1.31 once I run the newest version it freezes

Sent from my KFTT using Tapatalk

11-17-2014, 10:41 AM
I know the Grinch is listed as OK but wanted to add running Vixen 3.1u1 with an E682 with one port set to Renard and connecting a RenT-RnC-Grinch combo and using the home made (Simple RenT Design) you have to lift pin 1 & 2 of the Ren-T off of ground because those 2 pins art part of your data input instead of ground and then it will work fine. This drove me up a wall for hours because it worked fine in the serial port but did not work when I moved it to the E682.