PDA

View Full Version : A Request..



DereckR
10-19-2012, 12:08 AM
Could someone possibly impliment this into Vixen or HLS? It is software for a Rockband Stage Kit that includes fog machine strobe light and a multiple LED board that does cool thing. I am using this for halloween show and this software works great but wish could include it into vixen or HLS? The source code is provided and everything i just dont know how to do it. Let me know.

http://sklightworks.com/

Thanks,
Dereck

mheuer
10-19-2012, 09:12 AM
Controlling one of those with Vixen might be accomplished by writing a Vixen plug-in.

I wrote a quick Vixen 2.1 plug-in from the info you provided, you might see if it'll work.

From the attached zip file below, copy StageKit.dll and VixenStageKit.dll into Vixen's /Plugins/Output/ folder.

The plugin requires 34 channels to control the kit, assigned in the following order:
1-8 = Red LEDs
9-16 = Green LEDs
17-24 = Blue LEDs
25-32 = Yellow LEDs
33 = Strobe (Dimming level determines the blink speed)
34 = Fogger

See the test sequence included in the attachment, it should show how the channels are layed out.

Good luck, :)
Mike.

DereckR
10-19-2012, 09:15 AM
Sweet will test tonight thank you so much you just made my day. Didn't expect it that fast lol figured was simple considering it is the controller built in so.

DereckR
10-19-2012, 06:25 PM
Tried to play the test sequence all the lights fog and strobe are all on once it starts then when stop all off.

mheuer
10-20-2012, 07:59 AM
That's odd. Here's another attempt, attached is the updated VixenStageKit.dll.

I temporarily disabled the fogging while we try to get the LEDs and strobe working, don't want to waste all your fog fluid lol.

DereckR
10-20-2012, 04:08 PM
ok the leds are working and the strobe control also turns on and off correctly so what do we need to do to add the fogg again? or just try the fog?

DereckR
10-20-2012, 04:08 PM
the fog is working with this one as well lol. But how do i control the rate of the strobe again?

DereckR
10-20-2012, 04:12 PM
Well lets say it did the first time now it wont... Strobe and lights work fine now just the fog needs the tune. Have a halloween party tonight this is going to make it sweeet:)

DereckR
10-20-2012, 05:40 PM
Here is what it looks like if anyone wants to see it.

http://www.youtube.com/watch?v=Zhyl2yZA-BY

mheuer
10-21-2012, 05:26 AM
Nice video! :)

Here's a version with the fog added in, hopefully I got it working right this time lol.


But how do i control the rate of the strobe again?
Vixen allows for dimming levels between 0 and 255, but the strobe itself only supports 4 individual speeds.
So I assigned dimming levels between 50/100/150/200 to Slow/Medium/Fast/Fastest respectively.

Doing a long ramp/fade on the strobe channel should step into each of the 4 speeds.
Well, its supposed to work like that anyways, let me know if it doesn't.

Happy blinking :)

DereckR
10-21-2012, 12:44 PM
Works :))) Ty very much