PDA

View Full Version : usb to serial port ren t renc olsen 595 problem



craftylag
07-09-2012, 11:08 AM
Here is my problem. using a laptop with Vista(Not my choice a hand me down)I have a heart beat on the ren c with power on ren c and 595. I only have first 8 channels with 595 chip and I have changed them as well. when I start the sequence the rx d7 led lights up but the first 8 channels stay on. The sequence starts out with all channels off. Please Help. I must be over looking something.

P. Short
07-12-2012, 01:38 PM
Do you have all eight 595 chips installed?

craftylag
07-13-2012, 10:00 AM
No just one 595 and one uln2803. I also tried my wife's dell laptop same result. Voltage reading are pin 11- 2.25v pin 12 .75v pin 14 0v If I can remember right shouldn't I have some voltage on pin 14 on the 595(with the sequence running). Thanks Paul for taking time to help with my problem. I am in Mrytle Beach with not a lot to work with. Made a flag for July Fourth and had no blinkly liights. What a disapointment.

craftylag
07-13-2012, 11:43 AM
Sorry Phil I was in the Army with Paul Short.

P. Short
07-16-2012, 07:30 AM
OK, best advice is to try and find someone local who can help you.

One thing that stands out is that you are using only one 595 chip. It would be best if you had all eight 595 chips installed, even if you are only using one of them. If that doesn't work for you (e.g. you only have one chip), removing the 'second' cable between the Ren-C and the 595 board might help. This assumes, of course, that both boards have a proper regulated 5V power present on them.

jpb
07-17-2012, 08:11 AM
I am in no way an expert but does the Renard protocol output the last channel first and then work backwards to channel one? I seem to remember this from a few years back when I burnt out a couple of my Grinch chips and had to redo the REN-C software to support the lower number of channels.

My other suggestion is create a parallel connector and run straight from your PC to the 595 to prove the problem into the 595 or the REN-C

Jon

craftylag
07-17-2012, 12:18 PM
I am back in Ohio to pickup my grandson to go back to Mrytle Beach and I will take a working Grinch back with me. I was running one chip thinking to limit any other problems. If the protocol output is last channel first I may have added to the problem. I did have a spare ren c with me and they both had heartbeat with no errors power and D7(Rx) lit. The Usb to serial adapter is set at 57600. I also went thru the 595 troubleshooting steps and it did check out ok. That is were I got the placement of first chip and proceed to next. Forgot about renard. Has to be something simple just not thinking right. Thanks for helping. If anybody is interested I am planning to build another flag and can take pictures as I go.