PDA

View Full Version : Problems with editor loosing cursor



jrock64
02-01-2012, 03:28 PM
Has anyone else has problem with the post editor since the BIG CRASH.

When trying to add or reply to a post it will loose the cursor, as soon as you use the arrow key to move the cursor within existing text.
Makes it difficult to edit text you have already typed.

If it has always done this, I had not noticed it before.

My browser is FireFox.

Joel

kychristmas
02-01-2012, 05:50 PM
It's not since the Crash, it's since the change in JS WYSIWIG Editors. I think you can acutally switch back. It does other weird things too. Like duplicating text when a line wraps in a certain way.

51fordf2
02-01-2012, 07:32 PM
I drag the bottom right corner, to quite a ways below the last text. Then it doesn't jump


R

Macrosill
02-02-2012, 09:04 AM
I have never had this issue. What OS, browsers are you using? I need specific versions.

ErnieHorning
02-02-2012, 02:53 PM
I’m using IE 8.0.7600.16385 on Windows 7-32 bit at work and don't see the problem.

I'm using Windows 7-64 bit (Home Premium) Vers 6.1 (Build 7601: Service Pack 1), IE 9.0./112.16421 at home and the cursor disappears when I move the cursor with the arrow keys. If you wait, it will show after 10 seconds or so. If you click to move it, it’s there right away.

I typically use a word processor on that system because the on-line spell checker doesn't work well when crossing over sentences on that computer so I don't see it as often. I assumed it was a problem only on 64-bits and found a work around.

I figured this was only a temporary issue and it would be fixed when our stellar administrator had the time to work on the site again.

kychristmas
02-02-2012, 03:12 PM
I figured this was only a temporary issue and it would be fixed when our stellar administrator had the time to work on the site again.

Brown-Noser!

I am running IE 9.08 - I see both the wrapping issues with what appear to be duplicated text that isn't really there as weill as the disappearing cursor. It's not a big deal to me, but would be nice. I occassionally will use Chrome or Firefox and don't recall those issues.

Kelly

Macrosill
02-03-2012, 09:31 AM
So, both of you only see this behavior when using IE9?

jrock64
02-03-2012, 09:38 AM
But the OP has always been on FireFox.
Most current version

JOel

Macrosill
02-03-2012, 10:53 AM
Joel,
Which version of FF are you running?

I run W7, XP and Vista with the most current version of FF at the time and have not seen this behavior, or at least I have not noticed it.

jrock64
02-03-2012, 12:46 PM
curent version says
Firefox 9.0.1

Still did it as I typed this in the Quick reply box.

The advanced editor seems to be behaving today.

Joel

kychristmas
02-03-2012, 12:56 PM
So, both of you only see this behavior when using IE9?

I just really don't know. I typically only use Firefox to read stuff. I don't recall it. I'll try to use it and let you know. I AM certain that its happening with IE9.

Zeph
02-03-2012, 01:46 PM
I also see the duplicated text fragments in edit box, as somebody mentioned - IE9 on Win7Home. Haven't lost the cursor yet.

kychristmas
02-03-2012, 02:21 PM
Here's a new piece of information...

I just noticed that I lost my cursor while editing a Page on my website in JOOMLA. It's not the same editor either, but they could be using similar JS Libraries with the same issue. When I have more time, I'll research it.

mschell
02-03-2012, 03:07 PM
Are you sure it's not something like the touchpad on your laptop or a mouse that's misbehaving?

I have never seen this happen to me in this forum. I did have a mouse that liked to double click by itself or do a random click that caused weird things, but not that...

budude
02-03-2012, 03:28 PM
There are definitely known issues with many touchpads and Windows 7 where the cursor moves around wildy at times (mine does at home for example) but I don't think this is the same issue as here...

kychristmas
02-03-2012, 07:10 PM
Are you sure it's not something like the touchpad on your laptop or a mouse that's misbehaving?

I have never seen this happen to me in this forum. I did have a mouse that liked to double click by itself or do a random click that caused weird things, but not that...

Just to be clear. It's not moving, it's disappearing. If I type, the characters go where I expect them. The cursor is not a mouse thing. The pointer would be a mouse thing. While the cursor can be set by the mouse/pointer, it's ultimately a keyboard-related thing.

I use multiple keyboard and mice. At work my lapto is plugged into a different mouse. In my home office I use a docking station with keyboard and mouse. While watching TV, I generally run on Battery with the Eraser Head and built-in keyboard.

I'm pretty literate when it comes to hardware. I won't say it's for sure not hardware related, but I doubt it. I don't see the issue in any other editor such as Word, Notepad, Visual Studio, etc.. Like I said, seems to be Javascript related.

Kelly

ErnieHorning
02-03-2012, 09:57 PM
I don't see this issue with any other site or program. It's only the cursor, editing works fine.

I've seen the phantom words before. It happend when the window width was right on the edge of where a word would wrap to the next line. Change the width a little and it went away.

BTW, since we've started talking about this, I haven't see the problem. :hmm:

I am seeing the code for my signature instead of the end result in the advanced editor though. I didn't before.

jrock64
02-03-2012, 10:26 PM
I are not imagining this

http://www.businessadviceforum.com/showthread.php/28843-Editor-bug-known-issue-with-cursor-navigation-when-using-arrow-keys
http://www.ultimate-dvdr.com/feedback/45461-losing-my-cursor.html
http://newz.scriptz-team.info/vBulletin-vBulletin-Bugs/063535-VBIV-13545-Cursor-in-WYSIWYG-editor-disappears-when-using-arrow-keys-to-move-it.html


The advanced editor seems fine now

Joel

jrock64
02-03-2012, 10:29 PM
but the quick reply is still acting up

Any arrow movement makes the cursor disappear.

Joel

jrock64
02-03-2012, 10:39 PM
Just updated to
Firefox 10.0 and

no improvement on the quick reply

even if I make the window bigger.

Joel

The advanced editor still looks fine no matter what size the editing window is.

Macrosill
02-04-2012, 10:41 AM
Could someone get me a screen shot of what they are seeing? I am have difficulty understand exactly what is happening.

kychristmas
02-04-2012, 04:35 PM
Could someone get me a screen shot of what they are seeing? I am have difficulty understand exactly what is happening.

I tell you I don't think there is anything you can do about the cursor thing. I believe its a combination of things on the Client Side.

As for the weird wrapping issue. I only see it occassionally, but when it does happen I will be sure to grab a screen shot of it.

jrock64
02-06-2012, 01:49 AM
Chalk one up for Brian.
The upgrade appears to have fixed it.
The editor appears to work as expected now.

On both the Quick reply and the Advanced editor.

Case Closed.

Joel

ErnieHorning
02-06-2012, 10:58 AM
The upgrade appears to have fixed it.
The editor appears to work as expected now.

...

Case Closed.Mayby, maybe not.

After the upgrade, all of the menus are blank. If you hover the mouse over a menu selection, you can see a slight ghost.

ErnieHorning
02-06-2012, 11:00 AM
The upgrade appears to have fixed it.
The editor appears to work as expected now.

...

Case Closed.Mayby, maybe not.

After the upgrade, all of the menus are blank. If you hover the mouse over a menu selection, you can see a slight ghost. Selecting the item, still works.

Macrosill
02-06-2012, 11:01 AM
That is one of the minor issues I have to look into. It should just be a text color issue with the style.

kychristmas
02-06-2012, 03:11 PM
Mayby, maybe not.

After the upgrade, all of the menus are blank. If you hover the mouse over a menu selection, you can see a slight ghost. Selecting the item, still works.

May be the case, but it has nothing to do with the problem in the OP.