PDA

View Full Version : Olsen 595 Problems



davdue
11-24-2010, 07:35 PM
I have been using a 64 channel Olsen for 3 years now. This year with the same computer as last year and now it doesn't blink right. I have a test sequence that turns on each channel for one 100ms cycle in order. It blinks all the channels. The only change I have made was I jumped pins 18-25 together on the parallel connector. I also have a second 595 board now. But even without the second one it still doesn't work right. Any ideas?

RichF
11-24-2010, 08:52 PM
unjump pins 18-25 if that is the only change you have done I would say that is it.


but check you lpt port settings maybe the bios was reset.

davdue
11-24-2010, 10:35 PM
I found a broken wire on pin 2 of the DB25. But now I don't have any blinky flashy. I have the bios set for EPP but the device manager says EPC and I don't know how to change that. I deleted the port and had it scan for hardware changes but it comes back to EPC. Does any one have the voltage values I should see on the parallel port pins so I can verify the data is coming out. I have rung out the data cable and it is good. I also removed the pin 18-25 jumpers but to no avail. Help!!!! The light show is supposed to go on tomorrow evening.

davdue
11-25-2010, 12:43 AM
Ok I have tried 3 different computers now. They all act the same. Basically whatever outputs come on when the power supply is turned on stay on. The sequence has no affect on the Olsen outputs. I checked voltages on the RJ45 connector (while connected to the board) and I always get 0VDC on all data lines. One of the boards has been used for 3 previous years plus I have a brand new one I just built this year. Both boards act the same. Could I have screwed something up when I connected both of them up with the short cable from the out to the in? I just made a short 1 foot long Cat5 cable. It is really going to suck to have spent hours and hours putting up lights and have to go back to a static display if I can't get this working.

RavingLunatic
11-25-2010, 01:46 AM
Are you saying that the data lines coming from the parallel port are always 0VDC? If so, then your port is bad or your Vixen setup is incorrect or maybe your cable isn't pinned correctly (common error to get the pin order reversed).

Try using the Grinch troubleshooting guide to help you since they both use the parallel port.
http://www.doityourselfchristmas.com/wiki/index.php?title=Troubleshooting_Guide_The_Grinch#V ixen_Data_Problems

davdue
11-25-2010, 11:15 AM
Tried 3 different computers all the same result. All computers have Bios set at EPP & 378h. Using Olsen 595 plugin. It is set up as channels 1-64 as parallel 1. On one of the computers I know the port is good because I printed out my channel listing export file after I tested the Olsen board on it. My cable pin has been checked so many times I have lost count. It is wired as follows:

DB25 Color RJ45
1 White/Blue 5
2 Brown 8
14 White/Brown 7
18 White/Green 3

25 goes to ground of power supply (previous years only this was the case, first time powered up this year I had 18-25 all jumped, have since removed this)

This exact setup has worked for 3 years before. I am not sure I checked the data lines correctly. I put my meter ground on the power supply ground and checked the pins on the olsen input with the RJ45 connected to it. Like I said I have the old olsen board and a brand new one built this year. I have tested each individually with the same results.

1. What pins are what on the RJ45, ie, clock, data, latch, etc?
2. What voltages, approximately should I see on each line?
3. I am running Windows XP. In device manager the parallel port says EPC and no matter what I do (deleted and rescanned hardware) it comes back as that even though the bios says EPP. Is this correct?

I am beginning to think that I have some how trashed both boards 595 chips. I may have a few spares but not a whole two boards worth. I guess I could pull the chips out and check the data again or with the cable unplugged. Sorry for the long post but I wanted to detail everything I have done.

RavingLunatic
11-25-2010, 12:13 PM
To check to see if you are getting data to your chips, here is what I would do:

1 - Remove the first 595 chip (you could remove all the chips to ensure that one of them isn't dragging down the signals)
2 - Hook up the data cable like normal
3 - Run a test sequence (as described in the Grinch troubleshooting link provided above)
4 - Monitor the signals at the socket for the first chip

- Data line is 595 chip pin 14 (RJ45 pin 8)
- Clock line is 595 chip pin 11 (RJ45 pin 5)
- Strobe line is 595 chip pin 12 (RJ45 pin 7)
- GND is 595 chip pin 8 (RJ45 pin 3)
Voltages should be similar to those in the Grinch troubleshooting link provided. If you don't see similar voltages then you computer setup is still not correct (can't tell you how to fix it since every computer has its own quirks with BIOS).

To eliminate everything but the computer, you could monitor the signals directly at the parallel port on the computer.

davdue
11-26-2010, 10:48 PM
Thanks for the help Raving. I figured it out with the information you sent me. One thing I didn't mention in my diatribe before was that I had a loose connection in the RJ45 connector so I had replaced it. When I did I swapped 1 for 8 and 2 for 7 and so on! Whoops! With your info I was able to determine that and recrimped a new connector on and it works like a champ now. We have blinky flashy!!!! Just one day late but at least it works now. Thanks again. This forum is great.